Changes between Version 6 and Version 7 of docs_module_depend


Ignore:
Timestamp:
Jul 20, 2018, 6:42:07 AM (3 years ago)
Author:
ehb
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • docs_module_depend

    v6 v7  
    66 * the JSON to include at the top level of the module definition file lists tags and their values
    77 * the tags can be:
    8 || tag || value || example || description ||
     8|| tag || value || example(s) || description ||
    99|| base || string || "base" : "perl" || the primary language used - if applicable ||
    10 || cpan || string or list of strings || "cpan" : [ "JSON", "MIME::Base64" ] || CPAN modules to install ||
    11 || pip || string or list of strings || "pip" : "numpy scipy matplotlib" || Python PIP packages to install ||
    12 || cmd || string or list of strings || "cmd" : "git clone !https://github.com/ehb54/jspdb.git" || command to be run ||
    13 || cmd-os || string or list of strings || "cmd-ubuntu" : "apt install someapt" || os specific command to be run ||
    14 || cmd-os-version || string or list of strings || "cmd-ubuntu-16" : "apt install someapt" || os-version specific command to be run ||
    15 || file || string or list of strings || "file" : [ "my-dependency-1", "my-dependency-2" ] || extra files needed, note the defined executable is not needed ||
     10|| cpan || string or list of strings || "cpan" : "JSON" [[BR]]"cpan" : [ "JSON", "MIME::Base64" ] || CPAN module(s) to install ||
     11|| pip || string or list of strings || "pip" : "numpy scipy matplotlib"[[br]]"pip" : [ "numpy scipy", "matplotlib" ] || Python PIP package(s) to install ||
     12|| cmd || string or list of strings || "cmd" : "git clone !https://github.com/ehb54/jspdb.git"[[br]]"cmd" : [ "git clone !https://github.com/ehb54/jspdb.git",  || command(s) to be run ||
     13|| cmd-os || string or list of strings || "cmd-ubuntu" : "apt install someapt"[[br]]"cmd-centos" : [ "yum install xyz", "mkdir -p /x/y/z" ] || os specific command(s) to be run ||
     14|| cmd-os-version || string or list of strings || "cmd-ubuntu-16" : "apt install someapt"[[br]]"cmd-centos-7" : [ "yum install xyz", "mkdir -p /x/y/z" ] || os-version specific command(s) to be run ||
     15|| file || string or list of strings || "file" : "somefile"[[br]]"file" : [ "my-dependency-1", "my-dependency-2" ] || extra file(s) needed, note the defined executable is not needed ||