Changes between Version 12 and Version 13 of docs_module_depend


Ignore:
Timestamp:
Jul 20, 2018, 1:28:31 PM (3 years ago)
Author:
ehb
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • docs_module_depend

    v12 v13  
    1414|| run-os-version || string or list of strings || "run-ubuntu-16" : "apt install someapt"[[br]]"run-centos-7" : [ "yum install xyz", "mkdir -p /x/y/z" ] || run os-version specific command(s) ||
    1515|| file || string or list of strings || "file" : "somefile"[[br]]"file" : [ "my-dependency-1", "my-dependency-2" ] || extra file(s) needed, note the defined executable is not needed ||
     16|| env || string or list of strings || "env" : "MYENV=xyz" [[br]] "env" : [ "MYENV=xyz", "MYENV2=abc" ] || environment variable(s) to set ||
    1617 * each tag can be repeated as many times as needed except for the "base" tag, which can only be entered once and must be the first entry
    1718 * the processing is in sequential order, so cmd's processed and file's will be added in the sequence specified.