Changes between Version 9 and Version 10 of docs_module_depend


Ignore:
Timestamp:
Jul 20, 2018, 7:02:00 AM (3 years ago)
Author:
ehb
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • docs_module_depend

    v9 v10  
    1414|| cmd-os-version || string or list of strings || "cmd-ubuntu-16" : "apt install someapt"[[br]]"cmd-centos-7" : [ "yum install xyz", "mkdir -p /x/y/z" ] || os-version specific command(s) to be run ||
    1515|| file || string or list of strings || "file" : "somefile"[[br]]"file" : [ "my-dependency-1", "my-dependency-2" ] || extra file(s) needed, note the defined executable is not needed ||
    16  * each tag can be repeated as many times as needed except for the "base" tag, which can only be entered once
     16 * each tag can be repeated as many times as needed except for the "base" tag, which can only be entered once and must be the first entry
    1717 * the processing is in sequential order, so cmd's processed and file's will be added in the sequence specified.